front end shimmy

Old 08-01-2017, 08:34 PM
  #1  
mikeshemi
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Jan 2004
Location: mogadore,ohio
Posts: 18
Default front end shimmy

I have a 98 camaro with a big block chevy engine. wilwood brakes all around. Stock front struts. Problem is after running 1/8 mile even if i just touch the brakes the steering wheel shimmys. The harder i push the harder the wheel shimmys. while coasting after run the car is fine. But touch brakes and woww look out. I've taken off rotors and put them on a brake lathe. perfectly straight. Put tires on a balancer and no problem. Realigned front end. nothing. cleaned rotors with 100 grit air sander. Bought new pads. Oh i have 10 runs on this setup. Shimmied 9 times. New bushings new tie rod ends, stock rack. I''m at wits end.,.could front end toe in be wrong for the big block chevy at 122 in 1/8. Stock factory setting on front end specs for alignment. Any suggestions will be appreciated. I'm sure this isn't something only i'm stuck with.
mikeshemi is offline  
Old 08-02-2017, 06:37 AM
  #2  
Harbone
Moderator
RACING JUNKIE
 
Harbone's Avatar
 
Join Date: Aug 2007
Posts: 4,027
Default

Turn the rotors with an on car brake lathe. There is probably some run out on the face of the hub causing the issue. Turning on the car eliminates that problem and cuts them straight on the car.
__________________
Chris

As close to "Normal" as I can get...
Harbone is offline  
Old 08-02-2017, 06:48 AM
  #3  
mikeshemi
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Jan 2004
Location: mogadore,ohio
Posts: 18
Default

I put the stock brakes back on the car. I'm going out sat and i will get back to you with the results. Thanks for the reply
mikeshemi is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service